Julian Joswig: IT Blog

FRITZ!Box: Nicht funktionierende LAN-LAN-Kopplung (Routing) bei fehlerhafter VPN-Konfiguration

Geschrieben am 03. Jan 2021, 12:17

Seit einigen Jahren bieten die weit verbreiteten AVM FRITZ!Boxen die Möglichkeit, VPN-Tunnel zwischen mehreren FRITZ!Boxen aufbauen zu können. Ich hatte geplant, mein eigenes Heimnetz mit dem meiner Eltern zu koppeln, um regelmäßig Backups von den Computern meiner Eltern erstellen zu können. Durch die VPN-Kopplung, auch LAN-LAN-Kopplung genannt, wäre eine Datenübertragung sicher und verschlüsselt möglich gewesen. Bei der Einrichtung der Konfiguration bin ich jedoch auf einen Fehler gestoßen, welcher zwar einen Verbindungsaufbau ermöglicht hat, jedoch kein Datentransfer zwischen den Netzen möglich war. Wie ich das Problem gelöst habe, möchte ich hier beschreiben.

Das Setup

Mein Setup sah in aller Kürze wie folgt aus:

  • Netzwerk 1 (Mein Heimnetz):
    • FRITZ!Box 1 (private Adresse: 192.168.178.1): FRITZ!Box 7490 mit OS-Version 07.21 (aktuelle Version bis dato)
    • Netzwerkkonfiguration: 192.168.178.0/24
    • Verfügt über öffentliche IPv4-Adresse sowie DNS-Name über Myfritz.net
  • Netzwerk 2 (Heimnetz einer Eltern):
    • FRITZ!Box 2 (private Adresse: 192.168.0.1): FRITZ!Box 7390 mit OS-Version 06.86 (aktuelle Version bis dato)
    • Netzwerkkonfiguration: 192.168.0.0/24
    • Verfügt über öffentliche IPv4-Adresse sowie DNS-Name über Myfritz.net

In den jeweiligen Netzwerken (Netzwerk 1 & 2) befinden sich jeweils eine Vielzahl von Geräten. Das Ziel war, einen Computer im Netzwerk 2 regelmäßig auf einen weiteren Computer in Netzwerk 1 zu sichern.

Das Problem

Die Einrichtung des VPN-Tunnels (LAN-LAN-Kopplung) zwischen den zwei FRITZ!Boxen war erfolgreich und eine Verbindung konnte aufgebaut werden. Trotz des erfolreichen Aufbaus konnte jedoch kein Datentransfer stattfinden. Das Symptom war ein Routing, welches fehlerhaft schien, der der Verbindungsversuch aus dem Netzwerk 1 in das Netzwerk 2 hinein nicht klappte. 

Ich begab mich also auf Fehlersuche.

Die Lösung

Bei der Diagnose der Konfiguration und der so genannten Ereignis-Logs auf den FRITZ!Boxen fiel mir auf der entfernten Box ein wiederkehrender Fehler auf:

03.01.21 10:36:49 VPN-Fehler: 95.91.247.201, IKE-Error 0x2027 [4 Meldungen seit 03.01.21 10:35:11]

Der oben hervorgehobene IKE-Error 0x2027 bedeutet grundsätzlich erstmal nichts anderes, als das beim Aufbau eines Tunnels ein Timeout erfolgte (Quelle: https://service.avm.de/help/de/FRITZ-Box-Fon-WLAN-7390/016/hilfe_syslog_122). Mir fiel jedoch auf, dass die hier genannte IP-Adresse (95.91.247.201) nicht zu der öffentlichen IPv4-Adresse der beiden FRITZ!Boxen gehörte.

Es stellt sich heraus, dass dies ein Relikt aus einem früheren Versuch war, einen VPN-Tunnel einzurichten. Nach Löschen der Konfiguration, welche regelmäßig den Timeout erzeugte, klappte der Datentransfer der just eingerichteten LAN-LAN-Kopplung.

Das Fazit

Es scheint, als wenn die VPN-Komponente von FRITZ!OS bei einer fehlerhaften Konfiguration, welche zu einem Timeout beim Versuch eines Verbindungsaufbaus führt, alle weiteren eingerichteten VPN-Konfigurationen stört.

Meine Empfehlung ist daher, bei nicht ordnungsmäß funktionierenden VPN-Tunneln die Konfiguration der anderen VPN-Tunnel, sofern es welche gibt, zu prüfen.

Julian Joswig

Julian Joswig Facebook Julian Joswig LinkedIn Julian Joswig Twitter Julian Joswig XING

Über diesen Blog

Was ist der Inhalt dieses Blogs, fragt ihr euch vielleicht? Mein Name ist Julian Joswig und ich bin großer Fan von IT und Technologie (hauptsächlich Linux, Server, Netzwerke und alle damit verbundenen Themen). Manchmal beiße ich mir an schwierigen Sachverhalten fast die Zähne aus. Habe ich jedoch eine Lösung gefunden, möchte ich diese mit der Welt teilen. Beruflich arbeite ich als Management Consultant in Deutschland mit Fokus auf IT und Business.

Neueste Artikel:

Artikelarchiv:

Twitter Timeline: